Alternate Layouts in InDesign CS6
Creating Multiple Versions When One Size Doesn’t Fit All

Scenario #1: You’ve just finished designing an 18”x24” poster, incorporating all the corrections from your client. The phone rings [queue up theme from Jaws]. It’s your client: “Would it be any trouble to also build a 17”x11” version of the poster? How hard could it be? Oh, and I still need the job first thing tomorrow morning. But I’m not sure about the size…”

Scenario #2: You’re creating content for the iPad using Adobe’s Digital Publishing tools, and you need to create both vertical and horizontal versions of your layout, and there’s a chance you’ll also need to create yet another set of layouts for an Android tablet.

In CS5/5.5, Scenario #1 could be solved by creating a new document, or by using multiple page sizes within the document. But Scenario #2 required that you create separate documents for each orientation.

Now, in InDesign CS6, both scenarios are easily solved by the new Alternate Layout feature, which allows the equivalent of multiple versions of a document within a single file. While this new feature is a boon to designers creating content with Adobe’s Digital Publishing tools in mind, it’s also beneficial to anyone faced with the need to create multiple sizes of any document.
InDepth: Alternate Layouts

Why not just create a duplicate document, you ask? The Alternate Layout feature offers some advantages:

» Text frames in the “child” layouts are automatically linked to the “parent” layout: Edit text in the parent layout, and then use the Links panel to update the descendant content in the child layout. Very cool!

» All pages reside in the same document, which facilitates preflighting, packaging, and export.

» You can keep track of all the alternate versions of your poster, ad, catalog, magazine, flyer, or whathaveyou in one place, without having to go searching for multiple documents.

You’ll find that Alternate Layout is not a standalone concept; it’s affected by Liquid Layout rules, and also benefits from the Content Collector/Placer. I’ll touch on those very supportive features, so you can get a glimpse of the whole picture. But for a more extensive study of the wonders of Liquid Layout, see Pariah Burke’s article in this issue. Go ahead; I’ll wait here.

Oh, you’re back!

Creating an Alternate Layout

You can create an Alternate Layout for a document of any size or orientation, with facing or non-facing pages. But since the most common motivation for using Alternate Layouts is to create content destined for tablet viewing, I’ll use that as my example. In my document, the initial page size is 768x1024 px, the vertical dimensions of the iPad 1 & 2. (The iPad 3 sports a 2048-x-1536 pixel screen. While that option isn’t available as a preset in the New Document dialog, you can just enter those values manually.)

NOTE: Liquid Layout and Layout Adjustment are mutually exclusive—if you enable Layout Adjustment, all Liquid Layout options will be disabled.

To create an Alternate layout, use one of these alternate (ha) methods:

» Choose Layout > Create Alternate Layout.

» In the Pages panel menu, choose Create Alternate Layout.

» In the Pages panel, right-click (or Control-click with a one-button mouse) on any small black-triangle section marker in the document thumbnails.

» Choose View Pages > By Alternate Layout in the Pages panel menu, and then click the small downward triangle to the right of a layout name at the top of the pages section of the Pages panel.

InDesign recognizes the orientation of the existing layout, assumes you want its complementary orientation, and populates the dimension fields accordingly. For example, if your initial layout is 768x1024 pixels, the new layout’s dimensions are set
InDepth: Alternate Layouts

Do not hallucinate.

1024x768 pixels (Figure 1). You’re not limited to just one alternate layout; you can have as many as you like. It’s a good idea to name your alternate layouts after their destiny—iPad_V, GalaxyTab_H, Poster_V, and so on.

If you use default settings when you create the alternate layout, the initial results are going to require extensive massaging—and probably make you think it would be just as easy to start from scratch (Figure 2). Quick: Undo!

Object-based Liquid Layout settings are usually the remedy. First, I set the frame-fitting options for the images to Auto-Fit, then select each image with the Page Tool to activate the Liquid Layout controls. I click the small padlocks for each axis to allow the image to scale with the page. In essence, I’m giving InDesign permission to change the frame size in accordance with 1024x768 pixels (Figure 1). You’re not limited to just one alternate layout; you can have as many as you like. It’s a good idea to name your alternate layouts after their destiny—iPad_V, GalaxyTab_H, Poster_V, and so on.

If you use default settings when you create the alternate layout, the initial results are going to require extensive massaging—and probably make you think it would be just as easy to start from scratch (Figure 2). Quick: Undo!

Object-based Liquid Layout settings are usually the remedy. First, I set the frame-fitting options for the images to Auto-Fit, then select each image with the Page Tool to activate the Liquid Layout controls. I click the small padlocks for each axis to allow the image to scale with the page. In essence, I’m giving InDesign permission to change the frame size in accordance with

WHERE’S MY ALTERNATE LAYOUT?

If you’re on a Master page, the option to create an Alternate Layout is available only via the small drop-down triangle next to a layout name in the Pages panel.

Figure 1: The default settings for Alternate Layout creation. In this instance, the primary layout is 768 x 1024 pixels—a vertical orientation—so InDesign automatically assumes that the new layout should be a horizontal orientation with the same dimensions.

Figure 2: With the default settings, my alternate layout is going to require extensive renovations. There’s a better way…
with the dimensions of the new layout. I also select text frames, and perform the same operation (Figure 3).

Now, when I create the Alternate Layout with the Object-Based Liquid Layout option, InDesign does the heavy lifting for me. The results are much better (Figure 4).

**Figure 3:** To ensure that the large image adheres to the top and sides of the layout, I select the frame and set the Liquid Layout options to pin those edges, resize with the page, and use Auto-Fit. This only takes seconds, and greatly improves the results. Here, I’ve used the Liquid Layout panel to specify the behavior for this frame.

**Figure 4:** By setting the frame fitting options to Auto-Fit, and using object-based Liquid Layout options that allow the frame to follow the dimensions of the new layout, I save a lot of work.

Whether you’re a blue-chip millionaire or you just want to pretend you’re one for a weekend, it’s worth the drive. Drive along the Blue Ridge Parkway to Halona’s Heliic Hulaoway. The drive itself is a race hugging heart-stopping curves, fevering up clear blue skies and your heart before your eyes. Just when you think you can’t stand any more, the world falls away, and you arrive at Halona’s Heliic Hulaoway. As the mountain golf of freshly-baked bread invades you, you know that your last breath with death was worth it: you’re in for a weekend of adventure and evergreen in the woody mountains of Helen’s 75-acre forest. Where else you can camp like a vagabond under the stars, while eating like a Vanderbilt?

**VIEWING ALTERNATE LAYOUTS**

**Tip #1:** To view alternate layouts side by side in the Pages panel, go to the Pages panel menu, and choose View Pages > By Alternate Layout.

**Tip #2:** To change the name of any layout, just click its name in the Pages panel, wait a second until the name highlighted, then type the new name.

**Tip #3:** To view layouts side by side in the main window, choose Window > Arrange > Split Window. Then, set each window to a separate layout within your document. While there’s no synchronized scrolling feature, you can still easily compare your layouts and tweak as necessary.
Relationships Between Layouts

Think of the original layout as the parent, and the new layout as its child. As with many parent/child relationships, there are limits to the family ties (not to mention two-way communications). Text frames on the original layout are automatically linked to the text frames on the new alternate layout. If text in the original frame is edited, the descendant frame in the alternate layout displays the Yellow Triangle of Terror to indicate that it’s a bit out of date (Figure 5). Update the out-of-date frame by clicking the yellow triangle on the frame (yes, that little badge is new in CS6, too), or by using the Update Link button in the Links panel. But editing text in a “child” frame on an alternate layout doesn’t spawn a corresponding alert on the frame or in the Links panel—it’s not a two-way process. So if you intend to synchronize the text in your layouts, remember to perform all edits on the original layout. If you edit the child frame, then subsequently make changes to the original parent frame, you’ll receive an alert when you attempt to update the text frame in the alternate layout (Figure 6). If you delete the original ancestral frame, the descendant frame doesn’t disappear; it just becomes a plain old independent text frame. Orphaned, if you will.

Figure 5: The link icon adorning a text frame in the alternate layout indicates its relationship with its ancestor on the original layout. Edit the parent frame, and the child frame displays a yellow alert triangle, as does its entry in the Links panel.

Figure 6: If you edit text in the alternate layout, and then make additional changes to the original text frame, and then update the “child” frame, you’re warned that you’ll lose all edits you had made in the alternate layout.

Two More Tips

Tip #1: You can select a “child” text frame and jump to the “parent” text frame by choosing Edit » Go to Source (which is a lot like Edit Original).

Tip #2: Each layout must have a unique name. Swatches and ruler measurements are universal in a document, not layout-specific, so you may not want to mix print and web layouts in the same document.
If you’re using paragraph and character styles (and you should be!), you can tell InDesign to clone them for each new alternate layout by enabling the Copy Text Styles to New Style Group checkbox in the Create Alternate Layout dialog box (Figure 7). For your convenience, they’re stored in separate style groups (folders). Initially, styles are identical between layouts, but you can redefine styles in each layout—there is no parent/child relationship between the styles; they’re linked only by their names. In other words, if you have a style called “bodytext” in one layout, it will still be called “bodytext” in the other layout, but you can define the new one completely differently if you want. This allows you to style text appropriately for each layout without starting over. Plus, if you delete an alternate layout, its duplicate styles disappear—easy housecleaning.

**Using the Content Collector, Content Placer, and Content Conveyor**

Despite the fact that the original layout is the basis for the descendant layout, this relationship is not like that of a document page to a Master page: Adding something to the original layout does not automatically add that content to alternate layouts.

When you create an alternate layout, existing text frames in the alternate are automatically linked to the original parent frames—but graphics are not. The assumption is that you’ll use the Links panel to update modified graphics, and the Relink option to introduce replacement graphics. It’s just One of Those Things, but there are other, more efficient ways to keep your layouts in sync.

First, if you change the attributes of an anchored graphics frame within a text frame on the original layout, those changes are telegraphed to any alternate layouts when you update the text frames on the other layouts! If you add a new anchored graphic object to a parent text frame, the object is seen as a text edit, and is also added to alternate layouts. If you...
InDepth: Alternate Layouts

replace a graphic in an anchored frame on the original layout, it’s also updated when alternate layouts are updated.

Second, the Place and Link feature (which in CS5.5 only created linked text frames) has now been expanded to create linked object frames, too. That means you can select an object on one layout, choose Edit > Place and Link (which loads the place cursor with the object on the page), switch to the new layout, and click. The “new” object is closely linked to the original. For example, if it’s an image frame and you change the image on the original layout, the frame shows up as Modified on the alternate layout, ready for you to Update. If you change the stoke weight on the original, you can update the linked version on the alternate layout, and it gets that stroke weight, too. Helpful!

The third method of keeping your layouts in sync is to use the new Content Collector and Content Placer tools. When you use the Content Collector tool to select objects, they’re added to the Content Conveyor, which automatically appears (Figure 8). Switch to the Content Placer tool

Figure 8: Use the Content Collector Tool to gather objects and store them on the Content Conveyor. Use the Content Placer Tool to deposit the Conveyor’s contents in the document. Options at the bottom of the Conveyor govern how objects are stored and placed. Warning: If a source document is closed, the objects harvested from it disappear from the Conveyor.
to place objects in an alternate layout, elsewhere within the same layout, or in another open document.

By default, when you collect and place using these tools, you just get duplicates of your page items. However, you’ll find that the Content Conveyor also provides methods for creating links between content, as well as mapping styles. The tiny “Create Link” checkbox in the Content Conveyor panel allows you to create a link as you place content into a new location (Figure 9). It’s like a little two-step: First, you choose the Content Collector tool, and gather up all the desired objects. Then, you select the target document, switch to the Content Placer tool, click the Create Link option, and plop the content into the target page, layout, or document.

Links are automatically created; if you alter the original object, its descendant displays a yellow triangle alert (Figure 10).

Just click the triangle to update the link.

To set up paragraph and character style mapping, first select the Content Placer tool, and then click the Style Mapping icon button to launch open the Custom Style Mapping dialog (Figure 11). Click New Style Mapping to create a new recipe, and select the source document. One little twist: A target layout or document must be the active document—if you’re still in the original donor document, you’ll only see its styles.

You can select a single object with the Content

---

**Figure 9:** Note the checkboxes for Create Link and Map Styles. The circled option allows you to set up Style Mapping.

**Figure 10:** The yellow alert triangle indicates an out-of-date link (from a modified image or linked parent frame).

**Figure 11:** The Content tools include an option for mapping styles between documents and layouts as content is placed.
Collector tool, or marquee-drag around multiple objects. You can also select objects with the Selection tool, and then choose Edit > Place and Link; the objects are subsequently added as one “stacked” entry set in the Conveyor (though they’re not grouped in the conventional sense). You can even load all the content in all the pages of a document or one of its layouts (Figure 12).

You can even use Place and Link or the Content Collector tools to transplant frames from one document to another, and the target remembers the donor document—make a change in the original, and the target (“child”) document sees and offers to update the link, even if the donor document has been closed.

Keep in mind that the Content Collector tools are useful in any project, whether you require alternate layouts or not. It’s a great way to scoop up content and deposit it wherever you need it, regardless of what you’re creating.

**Printing and Exporting Alternate Layouts**

When you print, or export to PDF (whether Print or Interactive), you can choose to print/export a single layout or all pages (Figure 13). If you select All Pages (like you’re probably used to doing), the resulting PDF will contain all layouts as one long string of pages (Layout 1, followed by Layout 2, etc.); there’s no demarcation between them, nor is the start of each layout automatically bookmarked. So you may elect to export each layout separately.

Alternate Layouts are actually a variation on document sections, but since each layout contains the same page-number range, exporting a single page or page range requires that you specify the complete name of the page to target it for output, by including its alternate layout name and page number. In other words, you can’t just say you want “page 1” anymore because there could be a page 1 in each one of your alternate layouts. Instead, when you choose Layout > Go to Page, for example, the drop-down list allows you to target a particular page within one of your layouts.
(Figure 14). In the Print or Export PDF dialog boxes, you can specify a particular page number in a layout by inserting the layout name followed by a colon. For example, you can jump to the third page of a layout called Letter H by typing “Letter H:3”.

Digital Publishing: Building Folios
As you might expect, the process of digital publishing is streamlined by the use of alternate layouts. When you specify dual orientation in the Folio Builder panel, InDesign is clever enough to select the first set of vertical and horizontal layouts and populate the Portrait and Landscape options for you (Figure 15). Of course, you can select another layout for each. Now, rather than having to manually choose and upload a separate carefully-named InDesign document for each orientation of a digital publication, you can upload both orientations in one move.

Figure 15: When you choose the dual orientation icon in the New Folio dialog, InDesign automatically vacuums up the first vertical and horizontal layouts in articles you add.

How Will You Use Alternate Layouts?
If you’re creating content for tablet devices, Alternate Layouts (and the companion Liquid Layout and Content Placement tools) are going to make your life quite a bit easier—that’s their main purpose, after all. But print designers should find a lot to love in these new features—just don’t let your fickle customer know how easy it is to make all those sizes she keeps asking for!

Claudia McCue is the author of Real World Print Production with Adobe Creative Suite Applications (Peachpit Press, 2009) and Fearless Flash: Use Adobe® InDesign® CS5 and the Tools You Already Know to Create Engaging Web Documents (Adobe Press, 2010), a contributor to several other graphics arts books, and the presenter for “Acrobat X: Creating Forms” for Lynda.com. When not chained to the computer, she’s riding her motorcycle on country roads, singing in her helmet. She swears it’s the cure for writer’s block.

After 25+ years in real-world print production, she now teaches creative and production professionals how to use Adobe products without hurting themselves or others. Claudia is a Certified Technical Trainer and an Adobe Certified Expert for Photoshop, Acrobat, Illustrator, and InDesign. Read her blog at www.claudiamccue.com.